import Foundation
let pattern = #"(\d)(\+-|[\/*+-])(?=\d)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
998998+999
998998+-999
99*8998+-999
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1 $2 "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)