using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d)(\+-|[\/*+-])(?=\d)";
string substitution = @"$1 $2 ";
string input = @"998998+999
998998+-999
99*8998+-999";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}