use strict;
my $str = '998998+999
998998+-999
99*8998+-999';
my $regex = qr/(\d)(\+-|[\/*+-])(?=\d)/p;
my $subst = '$1 $2 ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";