re = /(\d)(\+-|[\/*+-])(?=\d)/
str = '998998+999
998998+-999
99*8998+-999'
subst = '$1 $2 '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result