#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)((?:[^.?!]+[.?!]\s+){3})"
Local $sString = "Some text goes here. The second sentence. The third one. And more. Even more. Still more. It's boring, but let's put some more sentences. Almost there. Ok, this is the last one. "
Local $sSubst = "\1\r"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)