re = /((?:[^.?!]+[.?!]\s+){3})/m
str = 'Some text goes here. The second sentence. The third one. And more. Even more. Still more. It\'s boring, but let\'s put some more sentences. Almost there. Ok, this is the last one. '
subst = '\\1\\r'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result