import Foundation
let pattern = #"((?:[^.?!]+[.?!]\s+){3})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"Some text goes here. The second sentence. The third one. And more. Even more. Still more. It's boring, but let's put some more sentences. Almost there. Ok, this is the last one. "#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\r"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)