import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:[^.?!]+[.?!]\\s+){3})";
final String string = "Some text goes here. The second sentence. The third one. And more. Even more. Still more. It's boring, but let's put some more sentences. Almost there. Ok, this is the last one. ";
final String subst = "\\1\\r";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}