use strict;
my $str = 'Some text goes here. The second sentence. The third one. And more. Even more. Still more. It\'s boring, but let\'s put some more sentences. Almost there. Ok, this is the last one. ';
my $regex = qr/((?:[^.?!]+[.?!]\s+){3})/mp;
my $subst = '\\1\\r';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";