package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((?:[^.?!]+[.?!]\s+){3})`)
var str = `Some text goes here. The second sentence. The third one. And more. Even more. Still more. It's boring, but let's put some more sentences. Almost there. Ok, this is the last one. `
var substitution = "\1\r"
fmt.Println(re.ReplaceAllString(str, substitution))
}