const regex = /((?:[^.?!]+[.?!]\s+){3})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:[^.?!]+[.?!]\\s+){3})', 'gm')
const str = `Some text goes here. The second sentence. The third one. And more. Even more. Still more. It's boring, but let's put some more sentences. Almost there. Ok, this is the last one. `;
const subst = `\1\r`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);