# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((?:[^.?!]+[.?!]\s+){3})"
test_str = "Some text goes here. The second sentence. The third one. And more. Even more. Still more. It's boring, but let's put some more sentences. Almost there. Ok, this is the last one. "
subst = "\\1\\r"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.