import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<[^>]*>([^<]*)<[^>]*>";
final String string = "<col id=\"7\" type=\"TEXT\"> Speaker</col>\n"
+ "<col id=\"7\" type=\"TEXT\"> Monitor</col>\n"
+ "<col id=\"7\" type=\"TEXT\"> TV</col>\n"
+ "<col id=\"7\" type=\"TEXT\"> Amp</col>";
final String subst = "<outline text=\"$1\"></outline>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}