import Foundation
let pattern = #"<[^>]*>([^<]*)<[^>]*>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<col id="7" type="TEXT"> Speaker</col>
<col id="7" type="TEXT"> Monitor</col>
<col id="7" type="TEXT"> TV</col>
<col id="7" type="TEXT"> Amp</col>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<outline text="$1"></outline>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)