const regex = /<[^>]*>([^<]*)<[^>]*>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<[^>]*>([^<]*)<[^>]*>', 'gm')
const str = `<col id="7" type="TEXT"> Speaker</col>
<col id="7" type="TEXT"> Monitor</col>
<col id="7" type="TEXT"> TV</col>
<col id="7" type="TEXT"> Amp</col>`;
const subst = `<outline text="$1"></outline>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);