$re = '/<[^>]*>([^<]*)<[^>]*>/m';
$str = '<col id="7" type="TEXT"> Speaker</col>
<col id="7" type="TEXT"> Monitor</col>
<col id="7" type="TEXT"> TV</col>
<col id="7" type="TEXT"> Amp</col>';
$subst = "<outline text=\"$1\"></outline>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;