// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)<[^>]*>([^<]*)<[^>]*>").unwrap();
let string = "<col id=\"7\" type=\"TEXT\"> Speaker</col>
<col id=\"7\" type=\"TEXT\"> Monitor</col>
<col id=\"7\" type=\"TEXT\"> TV</col>
<col id=\"7\" type=\"TEXT\"> Amp</col>";
let substitution = "<outline text=\"$1\"></outline>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}