#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\w*)?,(.*)?,\s?(\d+)?,(\w+)?"
Local $sString = "Jhon,12" Main Third ,2012,GR" & @CRLF & _
"" & @CRLF & _
"Lew,"291" Line (12,596,3)",2012,GR" & @CRLF & _
"" & @CRLF & _
",All, 1992,FR"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")