import re
regex = re.compile(r"^(\w*)?,(.*)?,\s?(\d+)?,(\w+)?", flags=re.MULTILINE)
test_str = ("Jhon,12\" Main Third ,2012,GR\n\n"
"Lew,\"291\" Line (12,596,3)\",2012,GR\n\n"
",All, 1992,FR")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")