const regex = /^(\w*)?,(.*)?,\s?(\d+)?,(\w+)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\w*)?,(.*)?,\\s?(\\d+)?,(\\w+)?', 'gm')
const str = `Jhon,12" Main Third ,2012,GR
Lew,"291" Line (12,596,3)",2012,GR
,All, 1992,FR`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}