// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\w*)?,(.*)?,\s?(\d+)?,(\w+)?").unwrap();
let string = "Jhon,12\" Main Third ,2012,GR
Lew,\"291\" Line (12,596,3)\",2012,GR
,All, 1992,FR";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}