re = /^(\w*)?,(.*)?,\s?(\d+)?,(\w+)?/m
str = 'Jhon,12" Main Third ,2012,GR
Lew,"291" Line (12,596,3)",2012,GR
,All, 1992,FR'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end