$re = '/^(\w*)?,(.*)?,\s?(\d+)?,(\w+)?/m';
$str = 'Jhon,12" Main Third ,2012,GR
Lew,"291" Line (12,596,3)",2012,GR
,All, 1992,FR';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);