using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\w*)?,(.*)?,\s?(\d+)?,(\w+)?";
string input = @"Jhon,12"" Main Third ,2012,GR
Lew,""291"" Line (12,596,3)"",2012,GR
,All, 1992,FR";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}