# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^\w+:\/|\G[^?\/]*)\/+/\1\//g;t' <<< "https://www.example.com//abc//def//ghi///?jkl=mno//pqr?"