using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^\w+:/|\G[^?/]*)/+";
string substitution = @"\1/";
string input = @"https://www.example.com//abc//def//ghi///?jkl=mno//pqr?";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}