import Foundation
let pattern = #"(^\w+:/|\G[^?/]*)/+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"https://www.example.com//abc//def//ghi///?jkl=mno//pqr?"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1/"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)