re = /(^\w+:\/|\G[^?\/]*)\/+/
str = 'https://www.example.com//abc//def//ghi///?jkl=mno//pqr?'
subst = '\\1/'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result