$re = '@(^\w+:/|\G[^?/]*)/+@';
$str = 'https://www.example.com//abc//def//ghi///?jkl=mno//pqr?';
$subst = "\1/";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;