use strict;
my $str = 'https://www.example.com//abc//def//ghi///?jkl=mno//pqr?';
my $regex = qr@(^\w+:/|\G[^?/]*)/+@p;
my $subst = '\\1/';
my $result = $str =~ s@$regex@$subst@rg;
print "The result of the substitution is' $result\n";