const regex = new RegExp('(^\\w+:/|\\G[^?/]*)/+', 'g')
const str = `https://www.example.com//abc//def//ghi///?jkl=mno//pqr?`;
const subst = `\1/`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);