#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?:[^:]+:){3}([^:]+).*"
Local $sString = "arn:aws:secretsmanager:us-east-1:123456789012:secret:catsndogs-3HieNb" & @CRLF & _
""
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)