re = /^(?:[^:]+:){3}([^:]+).*/m
str = 'arn:aws:secretsmanager:us-east-1:123456789012:secret:catsndogs-3HieNb
'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result