using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[^:]+:){3}([^:]+).*";
string substitution = @"\1";
string input = @"arn:aws:secretsmanager:us-east-1:123456789012:secret:catsndogs-3HieNb
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}