package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[^:]+:){3}([^:]+).*`)
var str = `arn:aws:secretsmanager:us-east-1:123456789012:secret:catsndogs-3HieNb
`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}