$re = '/^(?:[^:]+:){3}([^:]+).*/m';
$str = 'arn:aws:secretsmanager:us-east-1:123456789012:secret:catsndogs-3HieNb
';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;