#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ""((?:\\.|[\w\W])*?)"|(?:@\S+)?[\[{(].*?[\]\})]\S*|\S+"
Local $sString = "/tellraw @a[name="Arie1906", c=1] ~13 ~~ "quoted \"你好\"" {"rawtext": [{"text":"§bI am blue"}]} ASDA kjhkdjah [BE QUOTA] @[adada ad] []abc @Arie1906"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")