re = /"((?:\\.|[\w\W])*?)"|(?:@\S+)?[\[{(].*?[\]\})]\S*|\S+/
str = '/tellraw @a[name="Arie1906", c=1] ~13 ~~ "quoted \\"你好\\"" {"rawtext": [{"text":"§bI am blue"}]} ASDA kjhkdjah [BE QUOTA] @[adada ad] []abc @Arie1906'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end