use strict;
my $str = '/tellraw @a[name="Arie1906", c=1] ~13 ~~ "quoted \\"你好\\"" {"rawtext": [{"text":"§bI am blue"}]} ASDA kjhkdjah [BE QUOTA] @[adada ad] []abc @Arie1906';
my $regex = qr/"((?:\\.|[\w\W])*?)"|(?:@\S+)?[\[{(].*?[\]\})]\S*|\S+/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}