package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`"((?:\\.|[\w\W])*?)"|(?:@\S+)?[\[{(].*?[\]\})]\S*|\S+`)
var str = `/tellraw @a[name="Arie1906", c=1] ~13 ~~ "quoted \"你好\"" {"rawtext": [{"text":"§bI am blue"}]} ASDA kjhkdjah [BE QUOTA] @[adada ad] []abc @Arie1906`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}