const regex = /"((?:\\.|[\w\W])*?)"|(?:@\S+)?[\[{(].*?[\]\})]\S*|\S+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"((?:\\\\.|[\\w\\W])*?)"|(?:@\\S+)?[\\[{(].*?[\\]\\})]\\S*|\\S+', 'g')
const str = `/tellraw @a[name="Arie1906", c=1] ~13 ~~ "quoted \\"你好\\"" {"rawtext": [{"text":"§bI am blue"}]} ASDA kjhkdjah [BE QUOTA] @[adada ad] []abc @Arie1906`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}