using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""((?:\\.|[\w\W])*?)""|(?:@\S+)?[\[{(].*?[\]\})]\S*|\S+";
string input = @"/tellraw @a[name=""Arie1906"", c=1] ~13 ~~ ""quoted \""你好\"" {""rawtext"": [{""text"":""§bI am blue""}]} ASDA kjhkdjah [BE QUOTA] @[adada ad] []abc @Arie1906";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}