$re = '/"((?:\\\\.|[\w\W])*?)"|(?:@\S+)?[\[{(].*?[\]\})]\S*|\S+/';
$str = '/tellraw @a[name="Arie1906", c=1] ~13 ~~ "quoted \\"你好\\"" {"rawtext": [{"text":"§bI am blue"}]} ASDA kjhkdjah [BE QUOTA] @[adada ad] []abc @Arie1906';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);