# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/id="(entryID..)"/$("#$1");/g;t' <<< "id=\"entryID23\"
id=\"entryID76\"
id=\"entryID33\"
"