const regex = /id="(entryID..)"/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('id="(entryID..)"', 'g')
const str = `id="entryID23"
id="entryID76"
id="entryID33"
`;
const subst = `$("#$1");`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);