import Foundation
let pattern = #"id="(entryID..)""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
id="entryID23"
id="entryID76"
id="entryID33"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = ##"$("#$1");"##
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)