package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`id="(entryID..)"`)
var str = `id="entryID23"
id="entryID76"
id="entryID33"
`
var substitution = "$("#$1");"
fmt.Println(re.ReplaceAllString(str, substitution))
}