re = /id="(entryID..)"/
str = 'id="entryID23"
id="entryID76"
id="entryID33"
'
subst = '$("#$1");'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result