$re = '/id="(entryID..)"/';
$str = 'id="entryID23"
id="entryID76"
id="entryID33"
';
$subst = "$(\"#$1\");";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;