use strict;
my $str = 'id="entryID23"
id="entryID76"
id="entryID33"
';
my $regex = qr/id="(entryID..)"/p;
my $subst = '$("#$1");';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";